Tag: EIGRP

 

GRE tunnel simulation, common issues

GRE tunnel simulation, common issues

 

GRE tunnel simulation, common issues, ccna exam
1- Static route points to the tunnel.
If the Branch2 network 10.1 0.20.0/24 is unable to communicate with the Server UKgoodbye network 10.1 0.10.0/24 over the GRE tunnel.
Tunnel configuration
Branch2# show run

interface Tunnel0
ip address 192.168.30.2 255.255.255.252
tunnel source Serial5/3
tunnel destination 172.16.10.2

R2#show run
….
interface Tunnel0
ip address 192.168.30.1 255.255.255.252
tunnel source GigabitEthernet4/0
tunnel destination 192.168.15.2
….

2- A PPP chap hostname mismatch
For example if the chap hostname between R1 and Branch2, so the router R1 will not connected to router Branch2
PPP configuration on router Branch2, side 1
interface Serial5/3
ip address 192.168.15.2 255.255.255.252
encapsulation ppp
ppp authentication chap
ppp chap hostname R1
ppp chap password 0 passccna

PPP configuration on router R1, side 3
interface Serial5/3
ip address 192.168.15.1 255.255.255.252
encapsulation ppp
ppp authentication chap
ppp chap hostname Branch22
ppp chap password 0 passccna

The ppp authentication will fail because the “ppp chap hostname Branch22” is wrong, a PPP chap hostname mismatch is noticed between Branch2 and R1
ppp authentichation chap
Solution, changing the configuration on R1
PPP configuration on router R1, side 3
interface Serial5/3
ip address 192.168.15.1 255.255.255.252
encapsulation ppp
ppp authentication chap
ppp chap hostname Branch2
ppp chap password 0 passccna

3-Misconfigured on PPP multilink interface on the Branch1 router.
Branch1 and R1 linked using a PPP multilink interface, the configuration of the ppp multilink could cause WAN connectivity issue “Branch1 router lose WAN connectivity with R1 router”.
PPP multilink interface

3.1 PPP multilink configuration on R1
R1#show run

interface Multilink1
ip address 192.168.14.1 255.255.255.252
ppp multilink
ppp multilink group 1

interface Serial5/0
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1
serial restart-delay 0
!
interface Serial5/1
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1
serial restart-delay 0

3.1 PPP multilink configuration on R1
Branch11
#show run

interface Multilink1
ip address 192.168.14.1 255.255.255.252
ppp multilink
ppp multilink group 1

interface Serial5/0
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1
serial restart-delay 0
!
interface Serial5/1
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1
serial restart-delay 0

4- The Branch3 LAN network 192.168.10.0/24 is not advertised into the EIGRP network.
The routing protocol used on this simulation lab is EIGRP, verifying its configuration on the router Branch3, we noticed it should be a subcommand like network 192.168.10.0 0.0.0.255
Branch3#show run | b router
router eigrp 666
network 192.168.16.0 0.0.0.3
eigrp router-id 3.3.3.3

To Branch3 LAN network 192.168.10.0/24 is not advertised into the EIGRP network, the configuration must be:
Branch3#show run | b router
router eigrp 666
network 192.168.16.0 0.0.0.3
network 192.168.10.0 0.0.0.255
eigrp router-id 3.3.3.3

Download now, the simulation lab done with GNS3 or practice practice ccna exam[download id=”4392″]

Practice lab Cisco CCNA R&S Serial Multilink and EIGRP Done on GNS3

Practice lab Cisco CCNA R&S Serial Multilink and EIGRP  Done on GNS3

It is recommended to GNS3 than pcket Tracer PP multilink.

EIGRP over multilink on GNS3

 

Step 1 Configuring multilink on router R1
R1(config)#interface multilink 13
R1(config-if)#ip address 192.168.16.2 255.255.255.252
R1(config-if)#ppp multilink
R1(config-if)#ppp multilink group 13
R1(config-if)#no shutdown

1.1 Configuring the interface serial5/0 on Router R1
R1(config)#interface Serial5/0
R1(config-if)#encapsulation ppp
R1(config-if)#ppp multilink
R1(config-if)#ppp multilink group 13
R1(config-if)#no shutdown

1.2 Configuring the interface serial5/1 on router R1
R1(config)#interface Serial5/1
R1(config-if)#encapsulation ppp
R1(config-if)#ppp multilink
R1(config-if)#ppp multilink group 13
R1(config-if)#no shutdown

Now, you should configure the router at other end in that case is the route R2

Step 2 Configuring multilink on router R2
R2(config)#interface multilink 13
R2(config-if)#ip address 192.168.16.2 255.255.255.252
R2(config-if)#ppp multilink
R2(config-if)#ppp multilink group 13
R2(config-if)#no shutdown

2.1 Configuring the interface serial5/0 on Router R2
R2(config)#interface Serial5/0
R2(config-if)#encapsulation ppp
R2(config-if)#ppp multilink
R2(config-if)#ppp multilink group 13
R2(config-if)#no shutdown

2.2 Configuring the interface serial5/1 on router R2
R2(config)#interface Serial5/1
R2(config-if)#encapsulation ppp
R2(config-if)#ppp multilink
R2(config-if)#ppp multilink group 13
R2(config-if)#no shutdown

Verify the multilink on router R1 and R2
R1#show ppp multilink
Multilink13
Bundle name: R2
Remote Endpoint Discriminator: [1] R2
Local Endpoint Discriminator: [1] R1

Bundle up for 00:23:23, total bandwidth 3088, load 1/255
Receive buffer limit 24000 bytes, frag timeout 1000 ms
0/0 fragments/bytes in reassembly list
0 lost fragments, 0 reordered
0/0 discarded fragments/bytes, 0 lost received
0x46 received sequence, 0x46 sent sequence
Member links: 2 active, 0 inactive (max 255, min not set)
Se5/0, since 00:23:23
Se5/1, since 00:23:11
No inactive multilink interfaces
R1#

R2#show ppp multilink
Multilink13
Bundle name: R1
Remote Endpoint Discriminator: [1] R1
Local Endpoint Discriminator: [1] R2
Bundle up for 00:25:42, total bandwidth 3088, load 1/255
Receive buffer limit 24000 bytes, frag timeout 1000 ms
0/0 fragments/bytes in reassembly list
0 lost fragments, 0 reordered
0/0 discarded fragments/bytes, 0 lost received
0x4C received sequence, 0x4C sent sequence
Member links: 2 active, 0 inactive (max 255, min not set)
Se5/0, since 00:25:42
Se5/1, since 00:25:29
No inactive multilink interfaces
R2#

Configuring EIGRP for IPv4 as routing protocol

Configuring EIGRP on router R1

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router eigrp 2
R1(config-router)#network 192.168.16.0 0.0.0.3
R1(config-router)#network 192.168.15.0 0.0.0.255
R1(config-router)#
*Sep  5 13:13:25.831: %DUAL-5-NBRCHANGE: EIGRP-IPv4 2: Neighbor 192.168.16.2 (Multilink13) is up: new adjacency
R1(config-router)#no auto-summary

Configuring EIGRP on router R2

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router eigrp 2
R2(config-router)#network 192.168.16.0 0.0.0.3
R2(config-router)#
*Sep  5 13:11:35.811: %DUAL-5-NBRCHANGE: EIGRP-IPv4 2: Neighbor 192.168.16.1 (Multilink13) is up: new adjacency
R2(config-router)#network 192.168.14.0 0.0.0.255
R2(config-router)#no auto-summary
R2(config-router)#end

Verifying the routing table

R1#show ip route eigrp
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override
Gateway of last resort is not set
D     192.168.14.0/24 [90/1343488] via 192.168.16.2, 00:13:18, Multilink13
EIGRP is using the bundle link, multilink 13

Download the lab, EIGRP over multink ppp,[download id=”4128″]

Cost, metric calculation for STP, RIP, OSPF and EIGRP

Cost, metric calculation for STP, RIP, OSPF and EIGRP

 Cost and/or Metric calculation
 STP  Based on an interface’s cost plus the cost listed in a received STP Hello message.
 OSPF calculates its metric (cost) by utilizing the sum of all interface costs settings for all links in a destination subnet.
 EIGRP  Calculates its metric based on a route’s slowest link speed and the cumulative delay associated with each interface on the way to the destination subnet.
 RIP  Calculates its metric (hops) based on the number of routers between a router and the destination subnet.

Router-ID selection, OSPF and EIGRP

Router-ID selection, OSPF and EIGRP

The routing protocol EIGRP and OSPF use the same criteria in order to the router ID. Is there any

  1. Manually router-id configured, if yes that will be router-id for router
  2. Loopback interface configured,  the router-id will be the highest IP address of the loopback interfaces.
  3. Last option, the router-id will be the highest IP address of the interfaces, up/up

 

Have a look to the next image, the router-id is 192.168.255.2 is that is highest IP address configured of the loopback addresses, because the command router-id A.B.C.D was not configured.

OSPF and EIGRP router-id

Router, Administrative Distance

Router, Administrative Distance

The administrative distance used by Cisco routers:

Administrative distance, cisco router

Route Source Default Distance Values
Connected interface 0
Static route 1
Enhanced Interior Gateway Routing Protocol (EIGRP) summary route 5
External Border Gateway Protocol (BGP) 20
Internal EIGRP 90
IGRP 100
OSPF 110
Intermediate System-to-Intermediate System (IS-IS) 115
Routing Information Protocol (RIP) 120
Exterior Gateway Protocol (EGP) 140
On Demand Routing (ODR) 160
External EIGRP 170
Internal BGP 200
Unknown* 255

The routers choose the routing source with the best administrative distance

 

AD: Administrative distance is the feature that routers use in order to select the best path when there are two or more different routes to the same destination from two different routing protocols. Administrative distance defines the reliability of a routing protocol.