Category: PAgp

 

PostgreSQL, Login disallowed for security reasons

PostgreSQL and phppgadmin installed, but unfortunately the login is disallowed for security reasons. Solution of ” Login disallowed for security reasons”
1. http://localhost/phppgadmin/

phpPgAdmin

A) Solution on Ubuntu
1) Edit the config.inc.php on /etc/phppgadmin and change the $conf[‘extra_login_security’] = true; from to false


	// If extra login security is true, then logins via phpPgAdmin with no
	// password or certain usernames (pgsql, postgres, root, administrator)
	// will be denied. Only set this false once you have read the FAQ and
	// understand how to change PostgreSQL's pg_hba.conf to enable
	// passworded local connections.
	$conf['extra_login_security'] = false;

2) Restart the postgresql using

sudo systemctl restart postgresql

3) and restart the

code>sudo systemctl restart apache2

phpPgAdmin

Configuring EtherChannel or Port-Channel

Configuring Static EtherChannel or Port-Channel

The term EtherChannel and Port-Channel can be used interchangeably to refer to the bundle of aggregated links, but Port-Channel or Po is the keyword used when configuring the interface.

PassCCNA(config)#interface fa 1/0/23
1.Static EtherChannel
PassCCNA(config-if)#channel-group ?
Channel group number

2.PassCCNA(config-if)#channel-group 1 ?
mode Etherchannel Mode of the interface

3.PassCCNA(config-if)#channel-group 1 mode ?
active Enable LACP unconditionally
on Enable Etherchannel only

The static etherchannel mode is “on” on both sides.

From this output, you can see the Cisco’s proprietary PAgp Port Aggregation Protocol has the mode Auto or Desirable and the standard Etherchannel LACP Link Aggregation Control Protocol(IEEE 802.3ad has the mode of Active or Passive

4. PassCCNA(config-if)#channel-group 1 mode on
Creating a port-channel interface Port-channel 1

Note:
Both interface should be configured with the same channel-group

4.1 PassCCNA2(config-if)#channel-group 1 mode on
Creating a port-channel interface Port-channel 1

5. Verify the configuration:
PassCCNA#show etherchannel summary

Flags: D – down P – bundled in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3 S – Layer2
U – in use f – failed to allocate aggregator
M – not in use, minimum links not met
u – unsuitable for bundling
w – waiting to be aggregated

d – default port
Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
——+————-+———–+———————————————–
1 Po1(SU) – Fa1/0/23(P)

5.1 Verify the configuration:
PassCCNA#show interfaces port-channel 1 etherchannel

Age of the Port-channel = 0d:00h:09m:51s
Logical slot/port = 10/1 Number of ports = 1
GC = 0x00000000 HotStandBy port = null
Port state = Port-channel Ag-Inuse
Protocol = –
Port security = Disabled
Ports in the Port-channel:
Index Load Port EC state No of bits
——+——+——+——————+———–
0 00 Fa1/0/23 On 0
Time since last port bundled: 0d:00h:09m:51s Fa1/0/23

5.2 Etherchannel
Once the etherchannel is created we can use the commands to check an interface like show interfaces,
PassCCNA1#show interface port-channel1
Port-channel1 is up, line protocol is up (connected)
Hardware is EtherChannel

If we shutdown the interface(FastEthernet1/0/23) associated with port-channel1, the port-channel1 will change from up to down too.

Statically we configured both end the same way.

7. Configuring Port Aggregation Protocol(PAgP)
The Cisco’s PAgP use:
auto Enable PAgP only if a PAgP device is detected
desirable Enable PAgP unconditionally

7.1 switch PassCCNA1- mode auto
PassCCNA1(config)#interface range fa1/0/2-3
PassCCNA1(config-if-range)#channel-group 1 mode auto
7.2 Configure switch PAssCCNA2 – mode desirable
PassCCNA1(config)#interface range fa1/0/2-3
PassCCNA1(config-if-range)#channel-group 1 mode desirable

8.Verify the etherchannel
PassCCNA1#show etherchannel summary
Flags: D – down P – bundled in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3 S – Layer2
U – in use f – failed to allocate aggregator
M – not in use, minimum links not met
u – unsuitable for bundling
w – waiting to be aggregated
d – default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
——+————-+———–+———————————————–
1 Po1(SU) PAgP Fa1/0/2(P) Fa1/0/3(P)

9. Configuring Link Aggregation Control Protocol(LACP)
PassCCNA1(config-if-range)#channel-group 1 mode ?
active Enable LACP unconditionally
passive Enable LACP only if a LACP device is detected

One side will be configured on passive mode and the other on Active mode.
9.1 LACP – Passive
PassCCNA1(config)#interface range fa1/0/5-6
PassCCNA1(config-if-range)#channel-group 1 mode passive

9.2 LACP – Active
PassCCNA2(config)#interface range fa1/0/5-6
PassCCNA2(config-if-range)#no channel-group 1
PassCCNA2(config-if-range)#channel-group 1 mode active

10.The EtherChannel Layer 3 ports

The EtherChannel Layer 3 ports are made up of routed ports. Routed ports are physical ports configured to be in Layer 3 mode by using the “no switchport” interface configuration command.
A routed port by definition is one that can have an IP address assigned to it.

The Layer 3 EtherChannel can be configured using statically or dynamically configured EtherChannel

For example:
Side 1
PassCCNA1(config)#interface range fa1/0/5-6
PassCCNA1(config-if-range)#no channel-group 1
PassCCNA1(config-if-range)#no switchport
PassCCNA1(config-if-range)#channel-group 1 mode on
Creating a port-channel interface Port-channel 1

Now we can assign an IP address to port-channel interface

PassCCNA1(config)#interface port-channel1
PassCCNA1(config-if)#ip address 192.168.16.1 255.255.255.0

Side 2
PassCCNA2(config)#interface range fa1/0/5-6
PassCCNA2(config-if-range)#no channel-group 1
PassCCNA2(config-if-range)#no switchport
PassCCNA2(config-if-range)#channel-group 1 mode on
Creating a port-channel interface Port-channel 1

Now we can assign an IP address to port-channel interface
PassCCNA2(config)#interface port-channel1
PassCCNA2(config-if)#ip address 192.168.16.2 255.255.255.0

Now the show etherchannel should display under port “RU”

PassCCNA1#show etherchannel summary
Flags: D – down P – bundled in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3 S – Layer2
U – in use f – failed to allocate aggregator
M – not in use, minimum links not met
u – unsuitable for bundling
w – waiting to be aggregated
d – default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
——+————-+———–+———————————————–
1 Po1(RU) – Fa1/0/23(P) Fa1/0/24(P)

Keep in mind that to create an etherchannel you need to make sure that all ports have the same configuration:
1)Duplex has to be the same.
*Mar 1 00:51:20.850: %EC-5-CANNOT_BUNDLE2: Fa1/0/23 is not compatible with Fa1/0/24 and will be suspended (duplex of Fa1/0/23 is half, Fa1/0/24 is full)

2)Speed has to be there same.
*Mar 1 00:42:20.993: %EC-5-CANNOT_BUNDLE2: Fa1/0/23 is not compatible with Fa1/0/24 and will be suspended (speed of Fa1/0/23 is 10M, Fa1/0/24 is 100M)
3)Same native AND allowed VLANs.
*Mar 1 01:15:13.733: %EC-5-CANNOT_BUNDLE2: Fa1/0/23 is not compatible with Fa1/0/24 and will be suspended (trunk encap of Fa1/0/23 is dot1q, Fa1/0/24 is auto)
4)Same switchport mode (access or trunk).
*Mar 1 01:03:26.439: %EC-5-CANNOT_BUNDLE2: Fa1/0/23 is not compatible with Fa1/0/24 and will be suspended (trunk mode of Fa1/0/23 is tunnel, Fa1/0/24 is dynamic)

show etherchannel port-channel explained

Need more information?, keep reading, Cisco